This time, you are supposed to find A+B where A and B are two polynomials.
Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 … NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < … < N2 < N1 <=1000.
Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output:
3 2 1.5 1 2.9 0 3.2
题目大意
两个多项式求和,每一行表示一个多项式。
每一行第一个数K表示有K个非0的项,每一项有指数 N 和系数 a
将结果按照和输入相同的格式进行输出,系数精确到小数点后一位。
题目分析
开个数组sum[1005],其中sum[i]表示指数为 i 的项的系数和。
最后遍历sum数组,找出非0项的个数,然后输出结果即可,要按照指数从高到低进行输出。
AC代码
#include <bits/stdc++.h>
using namespace std;
double sum[1005] = {0};
int main()
{
int k, i, x, cnt = 0;
double y;
for (i = 0; i < 2; i++) //2行
{
cin >> k;
while (k--)
{
cin >> x >> y;
sum[x] += y;
}
}
for (i = 0; i < 1005; i++)
if (sum[i])
cnt++;
cout << cnt;
for (i = 1004; i >= 0; i--)
if (sum[i])
printf(" %d %.1f", i, sum[i]);
return 0;
}