This time, you are supposed to find A×B where A and B are two polynomials.
Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K N1 aN1 N2 aN2 ... NK aNK
where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤NK<⋯<N2<N1≤1000.
Output Specification:
For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.
Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output:
3 3 3.6 2 6.0 1 1.6
题目大意
给出两个多项式,求多项式的乘积。
题目分析
NK最大是1000,所以乘积中指数最大为2000.
开一个数组ans[2005],ans[x]表示指数为x的项的系数。
两层循环,维护ans数组即可。最后将ans中的非零项按照要求的格式进行输出。
AC代码
#include <bits/stdc++.h>
using namespace std;
struct node
{
int n;
double v;
} a[2][10];
double ans[2005] = {0};
int main()
{
int i, j, k, cnt = 0;
for (i = 0; i < 2; i++)
{
cin >> k;
for (j = 0; j < k; j++)
cin >> a[i][j].n >> a[i][j].v;
}
for (i = 0; i < 10; i++)
for (j = 0; j < 10; j++)
ans[a[0][i].n + a[1][j].n] += a[0][i].v * a[1][j].v;
for (i = 0; i <= 2000; i++)
{
if (ans[i])
cnt++;
}
cout << cnt;
for (i = 2000; i >= 0; i--)
{
if (ans[i])
printf(" %d %.1f", i, ans[i]);
}
return 0;
}